Performance issue affecting the Multiplayer experience
Incident Report for Outriders status page
Resolved
The issue is now resolved.
Posted Jan 12, 2022 - 07:44 UTC
Investigating
We are investigating an issue that may result in degraded performance to Multiplayer components. We are working to resolve this as soon as possible
Posted Jan 12, 2022 - 01:31 UTC
This incident affected: Outriders (Multiplayer).