Performance issue affecting the Multiplayer experience
Incident Report for Outriders status page
Resolved
The issue is now resolved.
Posted Apr 07, 2021 - 22:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 07, 2021 - 22:00 UTC
Investigating
We are investigating an issue that may result in degraded performance to the Multiplayer. We are working to resolve this as soon as possible
Posted Apr 07, 2021 - 22:00 UTC
This incident affected: Outriders (Multiplayer).