Performance issue affecting the Multiplayer experience
Incident Report for Outriders status page
Resolved
The issue is now resolved.
Posted Sep 15, 2021 - 00:33 UTC
Investigating
We are investigating an issue that may result in degraded performance to the Multiplayer. We are working to resolve this as soon as possible
Posted Sep 15, 2021 - 00:10 UTC
This incident affected: Outriders (Multiplayer).