Outage affecting Core Game Components
Incident Report for Outriders status page
Resolved
The issue is now resolved.
Posted Apr 03, 2021 - 03:08 UTC
Investigating
We are currently investigating an issue that is affecting the availability of Core Game Components. We are working to fix this as soon as possible
Posted Apr 03, 2021 - 02:10 UTC
This incident affected: Outriders (Core Components).